Buscar por dos valores (por ejemplo, nombre o apellido).

Supongamos que el valor que buscamos está en la columna A.

Tenemos una hoja “Nombre” que tiene los nombres en la columna A, y lo que buscamos en la columna B.

Tenemos una hoja “Apellido” que tiene los apellidos en la columna A, y lo que buscamos en la columna B.

Usamos estas fórmulas:

=SI.ERROR(BUSCARV(A:A, NOMBRE!A:B,2,0),BUSCARV(A:A,APELLIDO!A:B,2,0))

=IFERROR(VLOOKUP(A:A, NOMBRE!A:B,2,0),VLOOKUP(A:A,APELLIDO!A:B,2,0))

Si el resultado de buscar en la hoja del nombre es un error, busca en la hoja del apellido.

La siguiente variante de la fórmula muestra «No lo encontré» en vez de #N/A si no encuentra por nombre ni apellido.

=SI.ERROR(BUSCARV(A:A, NOMBRE!A:B,2,0),SI.ERROR(BUSCARV(A:A,APELLIDO!A:B,2,0),»No lo encontré»))

=IFERROR(VLOOKUP(A:A, NOMBRE!A:B,2,0),IFERROR(VLOOKUP(A:A,APELLIDO!A:B,2,0),»No lo encontré»))

Share

15 comentarios en «Buscar por dos valores (por ejemplo, nombre o apellido).»

  1. como puedo comparar, columna A tiene nombre y apellidos, columna B tiene apellidos luego nombre, quiero comparar A contra B

  2. Hola, tengo varios apellidos y nombres completos como cerca de 2mil, a veces las personas dicen un nombre y un apellidos para que los busque sus datos en recursos humanos. Como hacer para buscar màs rapido 1 nombre y 1 apellido que es lo unico que se tiene. ejemplo: caicedo pinos romeo josefo, pero al tener muchos caicedos quiero buscar directamente caicedo romeo. Gracias.

  3. Hola tengo un problema. tengo una lista de apellidos y nombres juntos. Pero necesito validar porque los apellidos están digitados algunos mal. Ejemplo

    Pepppe Espinoza
    Juan Gutiérrrez

    Cómo puedes apreciar hay 3 ppp y 3 RRR
    Así hay varios errores en la lista no solo con estos caracteres. Necesito filtrar para enviar a validarlos. Tengo 58000 mil registró s. Estoy validando base de datos

    • Este es uno de los problemas más difíciles de automatizar. Podemos tener Erick, Eric, Erik. Aidé, Aideé, Haydeé, Haidé. Todos son válidos si así lo escribieron en el registro.

      Empecé a pensar en quitar en automático los valores que no son válidos, pero cambian de un idioma a otro. En español no se puede escribir «r» después de «m», pero hay un nombre «Imriel».

    • Si tienes Power Pivot se puede hacer con:

      =
      CONCATENATEX (
      FILTER (
      empleados,
      AND (
      NOT ( ISERROR ( SEARCH ( buscados[Nombre], empleados[Nombre completo] ) ) ),
      NOT ( ISERROR ( SEARCH ( [Apellido], buscados[Apellido] ) ) )
      )
      ),
      empleados[Clave],
      «, »
      )

      En una oportunidad hago un video, pero me puede tomar una rato.

  4. Como hago en excel para buscar nombres repetidos en unas filas, si en una aparece nombre completo (dos nombres y dos apellido) y en la otra fila aparece por ejemplo (un nombre y un apellido) o (dos nombres y un apellido)

    • Esto es de las cosas más difíciles de automatizar. Si siempre tuviéramos las mismas 4 palabras, sería un asunto fácil. El problema es que los siguientes son nombres posibles:
      María del Carmen Ramos Solórzano (3 palabras son nombre, 2 son apellidos)
      Guillermo del Toro Vázquez (1 palabra es nombre, 3 son apellidos)
      María de la Cruz Benitez (4 palabras son nombre, 1 es apellido)
      Miguel Falcón de la Garza (1 palabra es nombre, 4 son apellidos)

      Incluso, si tenemos un nombre como este:

      Juan Franco Velasco

      Es imposible saber con certeza (sin preguntarle a la persona) si tenemos un nombre y dos apellidos o dos nombres y un apellido.

      Por esto, a menos que todos los nombres estuvieran separados, y tuvieran el mismo número de letras, con la misma acentuación (García no es lo mismo que Garcia para Excel) se tiene que revisar manualmente.

  5. COMO CHECAR EN EXCEL DATOS DUPLICADOS SI TENGO EN UNA COLUMNA EL NOMBRE Y EN OTRA COLUMNA APELLIDO PATERNO Y EN OTRA COLUMNA APELLIDO MATERNO COMO COMPARAR DATOS DUPLICADOS QUE CHEQUE POR NOMBRE Y APELLIDOS LOS REPETIDOS

    • Hola Juan.

      Hay que concatenar los valores usando &. Por ejemplo: a2 & b2 & c2

      Luego seleccionas esa columna, vas a Inicio – Formato Condicional – Resaltar valores – Duplicados. Eso te señala los repetidos.

  6. Como le hago si quiero comparar dos listas de nombres y apellidos (6000) pero existen errores ortograficos, mayus y minus., espacios de mas, en lugar de Ñ es ?. Use el formato condicional (duplicadas) me elimino unos 1300 , y empece a checar de uno en uno y me encontre con lo expuesto arriba. Necesito una formula que me compare lo mas que se pueda de caracteres (un 80% de que estamos hablando de la misma persona. gracias

    • Hola Fernando.

      Hay dos funciones que te pueden ayudar:
      – ESPACIOS / TRIM.
      – SUBSTITUTE / SUSTITUIR.

      Supongamos que tienes en la celda A1 un nombre que tiene varios espacios.

      =espacios(a1)
      =trim(a1)

      Te quita los espacios del principio y el final y te deja un solo espacio entre cada palabra.

      y para cambiar caracteres, puedes usar esto:

      =SUBSTITUTE(A1,»?»,»ñ»)
      =SUBSTITUIR(A1,»?»,»ñ»)

      Esto le indica que sustituya en el texto que encuentra en A1 los signos de interrogación por eñes.

      Y puedes ponerlas una dentro de la otra. Esto sustituye la á por a, ? por ñ y quita espacios.

      =SUBSTITUTE(SUBSTITUTE(TRIM(A1),»?»,»ñ»),»á»,»a»)

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

*

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.