Cómo elegir la última celda con valores en Excel.

Esta pregunta me la mandó José Luis González, y me dijo que estaba bien compartirla:

Tengo un documento en Excel que es nuestro score card, y lo que me pidieron hacer es que en una celda determinada, aparezca el ultimo valor escrito en la misma comuna, te mando un ejemplo:

Ejemplo

Imagínate que son la misma columna solo que Q1 es una semana y quiero que parezca en total lo ultimo escrito.

Q2 es otra semana, pero en el mismo renglón y como ya escribí otro valor el otra celda ahora aparece el 3 y así sucesivamente….

En pocas palabras necesito que en la celda de total aparezca el valor de la ultima celda utilizada…

 Solución propuesta:

Se le dice: “Si d2 no está en blanco, entonces pon ese valor, y si no, si c2 no está en blanco, pon ese valor, y si no, si b2 no está en blanco, entonces pon ese valor, y si no, entonces pon el valor de a2.”

La fórmula es así para E2:

En inglés:            =IF(D2<>»»,D2,IF(C2<>»»,C2,IF(B2<>»»,B2,A2)))

En español:        =SI(D2<>»»,D2,SI(C2<>»»,C2,SI(B2<>»»,B2,A2)))

Share
Acerca de

Armando Franco tiene amplia experiencia en las áreas de sistemas, compras y proyectos. Cuenta con una Maestría en Administración de Tecnologías de Información, y las certificaciones Certified Purchasing Manager, Microsoft Office 2010 Specialist, Expert y Master.

2 Comentarios en “Cómo elegir la última celda con valores en Excel.
  1. Nicola Simonelli dice:

    Buenas tardes.
    En algunas versiones de Excel se debe cambiar la coma (,) por el signo de ounto y coma (;).

    • Hola.

      Eso depende de la configuración regional y de idioma. En Europa y América se usan al revés el punto y la coma. En América se escribe $1,234.00 y en Europa se escribe $1.234,00

      Por eso en las fórmulas con la región europea se usa punto y coma en vez de coma, que sería el punto decimal para los americanos.

      Muchas veces, en América seleccionan en la configuración regional y de idioma de Windows, en el panel de control, el idioma Español de España. Esto hace que los números se vean como en Europa. Si estás en América, usa Español del país que corresponda y se comportarán igual que todos los demás.

      Saludos.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

*

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.