Para eliminar el error #N/A al usar BUSCARV, CONSULTAV o VLOOKUP

A partir de Excel 2007 existe la función IFERROR, SI.ERROR o SIERROR (en las primeras versiones de Excel 2010 en español al que no le han instalado Service Packs).

Se inserta esto inmediatamente después del signo de igual:

IFERROR(
SI.ERROR(
SIERROR(

Y luego, al final de la fórmula original, se incluye una coma, el mensaje que queremos que aparezca (si es numérico, sin comillas; si no, entre comillas) y se cierra el paréntesis.

Aquí van unos ejemplos:

Tienes Escribes
Excel en inglés =VLOOKUP(a1, C:F, 3, false) =IFERROR(VLOOKUP(a1, C:F, 3, false), «No encontrado»)
Excel en español =BUSCARV(a1, C:F, 3, falso) =SI.ERROR(BUSCARV(a1, C:F, 3, falso), «No encontrado»)
Excel 2010 en español sin SP =CONSULTAV(a1, C:F, 3, falso) =SIERROR(CONSULTAV(a1, C:F, 3, falso), «No encontrado»)
Share
14 Comentarios en “Para eliminar el error #N/A al usar BUSCARV, CONSULTAV o VLOOKUP
  1. Neftali Socorec dice:

    He estado tratando de correr la consultarv pero no me da el valor 0 que necesito

    =SI.ERROR(CONSULTAV(A23,’Base ER’!$A$7:$N$93,2,FALSO),0)

    A que se debe mi problema, gracias por la ayuda

    • Hola Neftali.

      Esto te va a dar cero solamente si no encuentra el valor. Si da otro resultado, ese es el valor que está encontrando.

      ¿Qué valor regresa?

      Saludos.
      Armando.

      • Neftali Socorec dice:

        Gracias Armando, ese es el objetivo que me de el valor 0.00 si no encuentra el dato en la matriz.

        Me tira el siguiente mensaje la formula

        #¿NOMBRE?

        Si utilizo el =CONSULTAV(A22,’Base ER’!$A$7:$N$93,2,FALSO) si existe en la matriz me da el valor encontrado y sino me da #N/A y necesito que en vez de #N/A me de el valor 0.00 por eso estoy tratando de utilizar la condicionanrte si.error pero no me da el valor 0.00

        Saludos.

        Neftalí Socorec

        • Armando dice:

          Es porque estás usando una versión de Excel 2010 en español que no tiene actualizaciones. Si usas CONSULTAV, entonces tienes que usar SIERROR, sin el punto medio.

  2. Adolfo Quezada lopez dice:

    Hola buenas noches.
    Utilizo esta formula, para buscar valores en una matriz X y me los coloque en otra matriz Y ; =BUSCARV(A3,Pedidos!$B$3:$I$15,8,) , pero a donde mando buscar los valores $B$3:$I$15 es una matriz mas chica que la matriz Y, y no todos los datos buscados A3, se encuentran, al no encontrarlos me pone #N/A y no lo puedo quitar ya vi muchos tutroriales y nada.

    Gracias por la ayuda.

    • Hola.

      Modifica tu función para que se vea así:

      =SI.ERROR(BUSCARV(A3,Pedidos!$B$3:$I$15,8,0),»»)

      Es muy importante que le agregues un 0 dentro de tu BUSCARV, de lo contrario traerá resultados falsos.

  3. ivonne dice:

    siempre que realizo la formula con consultav me trae el valor de la primer fila y el resto me sale N/A pero los valores si existen

  4. Marisol Perez dice:

    Buenas Tardes

    Diseñe una hoja de cálculo para una actividad que realizó en mi trabajo pero tengo un problema con la función «CONSULTAV» cuando el valor no tiene resultado lo pone como cero y al momento de graficar mis valores se caí mi gráfico por esta situación hay alguna forma evitar esto.

  5. oswaldo dice:

    Me sirvio bastante mil gracias ya habia visto que era la funcion si.error pero no decia que habia q poner «No encontrado» y me aparecia demasiados datos algo asi pero ya qedo

  6. ANDRES FERNANDO AVENDAÑO CASTAÑO dice:

    Y si quisiera que el valor encontrado no lo traiga sino que en su colar me coloque «ENCONTRADO»! como seria la formula

    • Armando dice:

      si el VLOOKUP es

      =VLOOKUP(A1,B:C,2,0)

      Usa

      =IF(ISNA(VLOOKUP(A1,B:C,2,0)),»No encontrado», «Encontrado»)

    • oswaldo dice:

      lo q pones entre comillas en este ejemplo «No encontrado» es lo que sale en el las celdas en mi caso hize una calculadora de impuestos y los valores que ingrese en las comillas fueron $0 y asi me aparecio saludos

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

*

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.